System Status

Welcome to Stamp.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Unexpected Technical Problem
Incident Report for Status.Stamps.com
Resolved
This incident has been resolved.
Posted May 28, 2020 - 17:26 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 28, 2020 - 17:19 PDT
Investigating
Stamps.com is currently experiencing a technical issue that we are working to resolve. Our engineering team is working to resolve this issue as quickly as possible. We’ll share another update shortly.
Posted May 28, 2020 - 16:35 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser) and Stamps.com API (SWS/Web Services).