System Status

Welcome to Stamp.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Transaction Print History Delays
Incident Report for Status.Stamps.com
Resolved
The issue impacting some customers’ ability to view transactions in their Printed Postage History Report, Refund Section, and SCAN Forms has been resolved. We apologize for the inconvenience and thank you for your patience. If you are still having issues, please contact us.
Posted Dec 08, 2020 - 17:37 PST
Investigating
Stamps.com Engineers have identified an issue that may affect some of our customers' ability to see transactions in their Printed Postage History Report, Refund Section, and SCAN Form. We are working to quickly resolve this issue and will provide an update when it's available.  We apologize for the inconvenience.
Posted Dec 08, 2020 - 11:55 PST
This incident affected: Stamps.com Reporting Tools (Postage History, Refunds & SCAN Forms).