System Status

Welcome to Stamp.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Unexpected Technical Problem
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the technical issue and all systems are functioning normally. Thank you for your patience.
Posted Nov 30, 2020 - 08:52 PST
Investigating
The systems that monitor the Stamps.com service are indicating that there may be a problem that may impact some customers’ ability to use the service. We are working to quickly resolve this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Nov 30, 2020 - 08:10 PST
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser), Stamps.com Software (Printing Postage Using our Windows Application), Stamps.com API (SWS/Web Services), and Stamps.com Reporting Tools (Postage History, Refunds & SCAN Forms).