System Status

Welcome to Stamp.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Issues Printing Postage
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the postage printing issue. We apologize for the inconvenience and thank you for your patience. If you are still having issues, please contact us.
Posted Jul 28, 2021 - 13:21 PDT
Investigating
Stamps.com Engineers have identified an issue that may temporarily affect some of our customers' ability to print postage and shipping labels. We are working to quickly resolve this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Jul 28, 2021 - 11:54 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser) and Stamps.com API (SWS/Web Services).