Stamps.com Desktop Software | Issues With Loading Orders
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed this issue and all orders are being imported in real-time. We apologize for the inconvenience and thank you for your patience. If you are still having issues, please contact us.
Posted Jul 15, 2022 - 12:36 PDT
Investigating
Stamps.com Engineers have identified an issue that may temporarily affect some of our customers' ability to load orders. We are working to quickly resolve this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Jul 13, 2022 - 10:38 PDT
This incident affected: Stamps.com Software (Printing Postage Using our Windows Application).