Stamps.com System Status

Welcome to Stamp.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Stamps Software Crashing 1/24
Incident Report for Status.Stamps.com
Resolved
This incident has been resolved.
Posted Jan 24, 2025 - 17:34 PST
Investigating
We are aware of an issue related to the Stamps Windows software automatically closing during launch for some customers. Our engineering team is investigating this and an update will be provided as soon as one is available.
Posted Jan 24, 2025 - 11:22 PST
This incident affected: Stamps.com Software (Printing Postage Using our Windows Application).