Stamps.com System Status

Welcome to Stamps.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Postage Purchase Failures

Incident Report for Status.Stamps.com

Resolved

This incident has been resolved.
Posted May 08, 2025 - 10:11 PDT

Investigating

We are aware of an issue impacting some customers' ability to purchase postage. We are investigating this issue with our payment processor and will provide an update when one is available.
Posted May 08, 2025 - 08:34 PDT