System Status

Welcome to Stamps.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Stamps.com software - unable to view History tab
Incident Report for Status.Stamps.com
Resolved
The reported blank History page both in the Stamps.com software and web client has been resolved.
Posted 4 months ago. Apr 19, 2019 - 12:35 PDT
Update
We are continuing to investigate this issue.
Posted 4 months ago. Apr 19, 2019 - 12:33 PDT
Update
We are continuing to investigate this issue.
Posted 4 months ago. Apr 19, 2019 - 11:32 PDT
Investigating
We are currently investigating reports of the History page within the Stamps.com software being blank or displaying an error message
Posted 4 months ago. Apr 19, 2019 - 11:31 PDT
This incident affected: Stamps.com Reporting Tools (Postage History, Refunds & SCAN Forms).