Stamps.com System Status

Welcome to Stamp.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Stamps Software Issue 1/24
Incident Report for Status.Stamps.com
Resolved
This incident has been resolved.
Posted Jan 24, 2025 - 07:52 PST
Investigating
We are aware of a problem that may impact some customers’ ability to use Stamps.com Software. We are monitoring this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Jan 24, 2025 - 06:56 PST
This incident affected: Stamps.com Software (Printing Postage Using our Windows Application).