Stamps.com System Status

Welcome to Stamp.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Web App Login Issues
Incident Report for Status.Stamps.com
Resolved
This incident has been resolved.
Posted Dec 09, 2024 - 14:22 PST
Investigating
We are aware of an issue impacting ability to login to the Stamps Web App. We are investigating the issue and will provide an update as soon as one is available.
Posted Dec 09, 2024 - 13:45 PST
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser).