System Status

Welcome to Stamp.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Postage Purchase Issue
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the postage purchase issue and all systems are functioning normally. Thanks for your patience!
Posted 5 months ago. Jul 09, 2018 - 10:09 PDT
Identified
We are continuing to work on a fix for this issue. We will have an update as soon as we have more details.
Posted 5 months ago. Jul 09, 2018 - 09:55 PDT
Investigating
Stamps.com Engineers have identified an issue that may temporarily affect some of our customers' ability to purchase postage. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted 5 months ago. Jul 09, 2018 - 06:59 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser), Stamps.com Software (Printing Postage Using our Windows Application), and Stamps.com API (SWS/Web Services).