Transaction Print History Delays
Incident Report for Status.Stamps.com
Resolved
The issue impacting some customers’ ability to view transactions in their Printed Postage History Report, Refund Section, and SCAN Forms has been resolved. We apologize for the inconvenience and thank you for your patience. If you are still having issues, please contact us.
Posted Aug 20, 2021 - 12:43 PDT
Investigating
Stamps.com Engineers have identified an issue that may affect some of our customers' ability to see transactions in their Printed Postage History Report, Refund Section, and SCAN Form. We are working to quickly resolve this issue and will provide an update when it's available.  We apologize for the inconvenience.
Posted Aug 20, 2021 - 09:43 PDT
This incident affected: Stamps.com Reporting Tools (Postage History, Refunds & SCAN Forms).