Unexpected Technical Problem
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the technical issue and all systems are functioning normally. Thanks for your patience!
Posted Dec 30, 2019 - 10:37 PST
Update
We are continuing to investigate the online store issue.
Posted Dec 30, 2019 - 10:10 PST
Investigating
Stamps.com is currently experiencing a technical issue accessing the online store. Our engineering team is working to resolve this issue as quickly as possible. We’ll share another update shortly.
Posted Dec 30, 2019 - 09:14 PST