Stamps.com printing error
Incident Report for Status.Stamps.com
Resolved
This incident has been resolved.
Posted Jan 30, 2024 - 11:13 PST
Update
Engineers are continuing to investigate an issue that is returning an error when attempting to print postage to non contiguous states. An update will be provided once the root cause has been identified.
Posted Jan 30, 2024 - 09:08 PST
Update
We are continuing to investigate this issue.
Posted Jan 30, 2024 - 06:57 PST
Investigating
Stamps.com engineers are aware of an issue prompting users to update their software when attempting to print to non-contiguous US states or territories. We are currently investigating and will provide updates when available.
Posted Jan 30, 2024 - 06:50 PST
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser), Stamps.com Software (Printing Postage Using our Windows Application), and Stamps.com API (SWS/Web Services).