Issues Printing UPS Postage
Incident Report for Status.Stamps.com
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 14:10 PDT
Investigating
Stamps.com is aware of a technical issue that may temporarily affect some customers' ability to print UPS® shipping labels. We are actively monitoring this and will provide an update when it is available.
Posted Jul 25, 2024 - 09:04 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser), Stamps.com Software (Printing Postage Using our Windows Application), and Stamps.com API (SWS/Web Services).