Issues Printing Postage
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the postage printing issue and all systems are functioning normally. Thanks for your patience!
Posted Oct 08, 2019 - 10:44 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 08, 2019 - 10:25 PDT
Monitoring
We are continuing to investigate the issue.
Posted Oct 08, 2019 - 08:25 PDT
Investigating
Stamps.com Engineers have identified an issue that may temporarily affect some of our customers' ability to print postage and shipping labels. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted Oct 08, 2019 - 06:27 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser), Stamps.com Software (Printing Postage Using our Windows Application), and Stamps.com API (SWS/Web Services).