Issues Printing Postage
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the technical issue and all systems are functioning normally. Thanks for your patience!
Posted Jan 28, 2019 - 12:21 PST
Investigating
Stamps.com Engineers have identified an issue that may temporarily affect some of our customers' ability to print postage and shipping labels. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted Jan 28, 2019 - 11:58 PST
This incident affected: Stamps.com Software (Printing Postage Using our Windows Application).